Genius partially unavailable

Incident Report for EGYM

Resolved

We think the impact from the issue is over.
Posted Mar 03, 2026 - 12:35 CET

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Mar 03, 2026 - 12:26 CET

Identified

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Mar 03, 2026 - 12:18 CET

Investigating

We have acknowledged an incident. We are investigating this currently.
There is no need to notify us of this incident, we will inform you once the incident is resolved.
Posted Mar 03, 2026 - 11:43 CET
This incident affected: Genius.