User signup registration degradation

Incident Report for EGYM

Resolved

The incident is now resolved.
We have deployed a fix for the problem and the systems are now stable and under monitoring.
Please bookmark support.egym.com and visit the site for answers to frequently asked questions concerning your EGYM eco-system and an overview of contact options.
Posted Mar 03, 2026 - 21:07 CET

Investigating

A fix has now been applied and we are now monitoring it. We will provide an update in 30 mins.
Posted Mar 03, 2026 - 20:25 CET

Identified

The root cause has been identified and we are currently working on a remediation. We will provide an update in 30 mins.
Posted Mar 03, 2026 - 20:02 CET

Investigating

User signup request may experience some degradation. We are currently investigating the root cause. We will provide an update in 30 mins.
Posted Mar 03, 2026 - 19:31 CET
This incident affected: Wellpass and Branded Member App (BMA).